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1 Introduction 

Geofabric Surface Network is intended to be used in stream flow tracing operations, 
thus utilising the product’s full topological connection. The product can support the 
spatial selection of associated hydrological features (such as water bodies and 
catchments) as inputs for spatial analysis/modelling. 

This tutorial describes the steps required to create a subset of Geofabric Surface 
Network which retains topological relationships and can be used with tooling available 
in the standard ArcMap Utility Network Analyst toolbar. An example of performing a 
simple network trace is also provided. 

In Version 2 of the Geofabric, geometric networks have been built and are provided as 
a component of Geofabric products. To select a subset of Geofabric data, or to include 
your own Nodes in the network, a geometric network needs to be rebuilt to continue to 
utilise the products’ topological connectivity. 

1.1 ArcGIS Version 

The steps outlined in this tutorial use ArcGIS 10.0 (SP 3).  

The tutorial also includes steps for ArcGIS 9.3 in instances where they differ 
significantly from ArcGIS 10.0. 

1.2 Symbology 

The symbology used in this tutorial is based on the Surface Network LYR file. 
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2 Tutorial 

2.1 Download the Surface Network File Geodatabase (FGDB) from the 
Geofabric ftp site 

1. From the Bureau of Meteorology Geofabric website browse to Downloads and 
select Download the Geofabric data from the Geofabric FTP site. Select Geofabric 
Surface Network’s SH_Network ZIP file and save this to disk 

 

 
 

2. Unzip the downloaded file, making sure that the resulting folder ends with gdb 
(e.g. the contents of the SH_Network ZIP file should be unzipped to a folder 
called SH_Network_GDB). 

 

http://www.bom.gov.au/water/geofabric/index.shtml
ftp://ftp.bom.gov.au/anon/home/geofabric/
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2.2 Create a Surface Network FGDB structure to store subset data.   

1. Start ArcCatalog and navigate to SH_Network.gdb that was downloaded and 
unzipped in step 2.1. 

2. Right click SH_Network.gdb > Export > XML Workspace Document 

 

 

3. Select Schema Only, check Export Metadata and Specify the output XML file: e.g. 
SH_Network_Schema.xml, Choose [Next>]. 
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4. Choose [Include All], Choose [Finish]. 

 

 

5. In ArcCatalog create a New > File Geodatabase (FGDB) in your chosen directory 
and rename, e.g. SH_Network_MurrayDarling.gdb 

6. Right click SH_Network_MurrayDarling.gdb Import > XML Workspace Document  
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7. In the XML Workspace Document Wizard, select Schema Only, specifying the 
XML source to import as SH_Network_Schema.xml as created in step 2.2. Choose 
[Next>], then choose [Finish]. 
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2.2.1 Delete empty Geometric Network 

Open the new feature dataset SH_Network, and delete the Geometric Network’s 
SH_Network_Net (SH_Network_Net_Junctions will be automatically deleted).  

A new geometric network will be created later on in this tutorial for the data subset. 
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2.2.2 Delete empty tables 

1. Delete the original tables which are empty: 

 AHGFNetworkConnectivityDown 

 AHGFNetworkConnectivityUp 

 AHGFNetworkStream_FS. 

 

 

 

2. These tables will be created later on in this tutorial for the data subset. 

3. Close ArcCatalog to release any potential table locks 
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2.3 Create a subset of the Geofabric Surface Network FGDB feature 
classes 

1. Start ArcMap and add in the following feature classes from the data that was 
downloaded in the ZIP file in step 2.1: 

 AHGFCatchment 

 AHGFNetworkNode 

 AHGFNetworkStream 

 AHGFWaterbody. 

2. Select a subset of AHGFCatchment features, either: 

 manually 

 through flow tracing 

 by undertaking a Select by Location operation with your own spatial 
features (e.g. a Catchment Management Authority reporting region) 

 with selected Hydrology Reporting Regions AWRA Drainage Division or 
RiverRegion features.  

3. IMPORTANT: Due to artefacts of the stream feature derivation process used to 
create the features in the AHGFNetworkStream feature class, some stream 
features will slightly overlap the boundaries of features in AWRA Drainage 
Division and RiverRegion feature classes. 

The same is likely when generating stream feature selection sets based on a 
spatial intersection with your own features. Therefore, if full stream connectivity 
needs to be preserved, it is strongly advised to follow the methodology described 
below when subsetting Surface Network features with Hydrology Reporting 
Regions features.  

When subsetting Surface Network with your own spatial boundary features, it is 
recommended that you utilise stream tracing when creating the feature selection 
sets for exporting. The same advice is also relevant when subsetting the stream 
features (AHGFMappedStream and AHGFMappedNode) contained within Surface 
Cartography. 

4. In this example we will select Murray–Darling using the Hydrology Reporting 
Regions feature class AWRA Drainage Division which can be downloaded from 
the Bureau of Meteorology Geofabric website: 

 Browse to Downloads and select Download the Geofabric data from the Geofabric 
FTP site. 

 Select Hydrology Reporting Regions HR_Regions ZIP file and save this to disk 

 Unzip the downloaded file, making sure that the resulting folder ends with gdb 
(e.g. the contents of the HR_Regions ZIP file should be unzipped to a folder 
called HR_Regions_GDB). 

http://www.bom.gov.au/water/geofabric/index.shtml
ftp://ftp.bom.gov.au/anon/home/geofabric/
ftp://ftp.bom.gov.au/anon/home/geofabric/
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2.3.1 Subset AHGFCatchment 

1. From the previously downloaded HR Regions product, add the 
AWRADrainageDivision feature class and select the record where Division = 
‘Murray–Darling’ 

2. Click the Selection Menu > Select By location, and in the Select by Location 
Wizard: 

 Select features from, Target Layer(s): AHGFCatchment 

 Source Layer: AWRADrainageDivision, Use selected features 

 Use selected features 

 Spatial selection method: Target layer(s) features are within (Clementini) 
the Source layer feature, 

 Choose [OK]. 
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3. Open Attribute Table of AHGFCatchment which contains the selected features, 
click on the button Show selected records.  

Do not close the table as it is required in the next step. 

 

 

4. In the Table of Contents (TOC) right click AHGFCatchment > Data > Export 
Data. In the Export Data Wizard select Selected features into your newly created 
FGDB, e.g. SH_Network_MurrayDarling.gdb\AHGFCatchment_Temp.  

5. Choose No to Do you want to add the exported data to the map as a layer.  

6. Do not deselect the AHGFCatchment features as they are required later on. 
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2.3.2 Subset AHGFNetworkStream 

1. In the Attribute Table showing the selected AHGFCatchments from the previous 
step, select Table Options > Related_Tables > CatchmentDrainsToSegment : is 
drained by to select all topologically related Network Streams. 

 

 

2. The Table Attributes of AHGFNetworkStream is automatically returned with 
related records selected. 

3. In the TOC right click AHGFNetworkStream > Data >Export Data. In the Export 
Data Wizard, select Selected features into your FGDB, e.g. 
SH_Network_MurrayDarling.gdb\AHGFNetworkStream_Temp.  

4. Choose No to Do you want to add the exported data to the map as a layer.  
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2.3.3 Subset AHGFNetworkNode 

1. Make sure AHGFNetworkStreams features are still selected. Click the Selection 
Menu > Select By location, and in the Select by Location Wizard: 

 Select features from, Target layer(s): AHGFNetworkNode 

 Source layer: AHGFNetworkStream 

 Use selected features 

 Spatial selection method: Target layer(s) features intersect the Source layer 
feature  

 Apply a search distance, or buffer, of 0.000000000000178 Decimal 
Degrees, which is the SH Network Feature Dataset’s tolerance.  

When creating a subset of SH Network GDB, it is possible that ArcGIS will 
otherwise not select all the relevant AHGFNetworkNode features. 

Using this tolerance will ensure that all the nodes in AHGFNetworkNode will 
be selected in ArcGIS, which uses this tolerance when evaluating 
relationships between features. 

 Choose [OK]. 
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2. Open Attribute Table of AHGFNetworkNode which contains the selected features, 
and click on the Show selected records button. 

3. In the Table of Contents right click AHGFNetworkNode > Data > Export Data. In 
the Export Data Wizard, select Selected features into your FGDB, e.g. 
SH_Network_MurrayDarling.gdb\AHGFNetworkNode_Temp. 

4. Choose No to Do you want to add the exported data to the map as a layer.  
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2.3.4 Subset AHGFWaterbody 

1. Make sure AHGFCatchment features are still selected. Click the Selection Menu > 
Select By location, and in the Select by Location Wizard: 

 Select features from, Target layer(s): AHGFWaterbody 

 Source layer: AHGFCatchment 

 Use selected feature 

 Spatial selection method: Target layer(s) features intersect the Source layer 
feature 

 Choose [OK]. 

 

 

2. Open Attribute Table of AHGFWaterbody which contains the selected features, 
and click on the button Show selected records. 

3. In the Table of Contents right click AHGFWaterbody > Data >Export Data, and in 
the Export Data Wizard, select Selected features into your FGDB, e.g. 
SH_Network_MurrayDarling.gdb\AHGFWaterbody_Temp.  

4. Choose No to Do you want to add the exported data to the map as a layer.  
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2.4 Load subset data 

1. Save your ArcMap document and exit, thereby removing any potential table locks 
when working in ArcCatalog. 

2. Open ArcCatalog and navigate to the SH_Network feature dataset within the file 
geodatabase SH_Network_MurrayDarling.gdb created in step 2.2. 

3. Right click AHGFCatchment > Load > Load Data. 

   

4. In the Simple Data Loader Wizard: 

5. Choose [Next>]. 
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6. For Input data, browse to AHGFCatchment_Temp as created in step 2.3.1 

 Select AHGFCatchment and choose [Open] 

 Choose [Add] then [Next>]. 

 

 

7. Take default I do not want to load all features into a subtype, choose [Next>]. 

8. Accept default Target Field / Matching Source Field mappings, choose [Next>]   
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9. Select Load all of the source data. Choose [Next>] and then [Finish]. 

   

 

10. Using the Simple Data Loader Wizard, Load Data into the remaining three feature 
classes within the SH_Network feature dataset using the AHGF<Feature Class 
Name>_Temp files created in steps 2.3.1 to 2.3.4: 

 AHGFNetworkStream 

 AHGFNetworkNode 

 AHGFWaterbody. 
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11. Delete all temporary feature classes after they have been loaded. 

12. Close ArcCatalog to release any potential table locks when working in ArcMap. 

2.5 Create a subset of the Surface Network FGDB tables 

In the SH Network FGDB downloaded in step 2.1, there are three geodatabase tables 
which contain topological connectivity information about the AHGFNetworkNode and 
AHGFNetworkStream features. 

When the SH Network XML schema was imported in step 2.2, these tables were empty 
and deleted in step 2.2.2. They will now be recreated and populated for the subset 
data in SH_Network_MurrayDarling.gdb. 

These tables’ key attributes are listed below where the descriptive tables are taken 
from the Geofabric Product Guide which is available to download from: 

http://www.bom.gov.au/water/geofabric/documentation.shtml 

AHGFNetworkConnectivityDown 

This table contains the topological connectivity of the network when traversing the 
network with the digitised direction of the stream features i.e. traversing downstream. 
Each record in the table contains the HydroIDs of a pair of From and To nodes in 
AHGFNetworkNode feature class and the HydroID of the respective 
AHGFNetworkStream segment providing the connection. Records are also included, 
which have To and Segment ID values set to -1, explicitly indicating that the From 
node stored in that record is a terminus node.  

Table 1 - Key attributes of the AHGFNetworkConnectivityDown (downstream) table 

for Surface Network 

Key attribute Alias Description 
From_ID From_ID The HydroID for the AHGFNetworkNode 

To_ID To_ID The HydroID for the next downstream AHGFNetworkNode 

Segment_ID Segment_ID The HydroID for the corresponding AHGFNetworkStream 

feature 

 

http://www.bom.gov.au/water/geofabric/documentation.shtml
http://www.bom.gov.au/water/geofabric/documentation.shtml
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AHGFNetworkConnectivityUp 

This table contains the topological connectivity of the network when traversing the 
network against the digitised direction of the stream features i.e. traversing upstream. 
Each record in the table contains the HydroIDs of a pair of From and To nodes in 
AHGFNetworkNode feature class and the HydroID of the respective 
AHGFNetworkStream segment providing the connection. Records are also included, 
which have To and Segment ID values set to -1, explicitly indicating that the From 
node stored in that record is a terminal head node. 

Table 2 - Key attributes of the AHGFNetworkConnectivityDown (downstream) table 

for Surface Network 

Key attribute Alias Description 
From_ID From_ID The HydroID for the AHGFNetworkNode 

To_ID To_ID The HydroID for the next upstream AHGFNetworkNode 

Segment_ID Segment_ID The HydroID for the corresponding AHGFNetworkStream 

feature 

AHGFNetworkStream_FS 

The content of the Flow Split (FS) table together with NextDownID attribution 
contained within the AHGFNetworkStream feature class jointly make up the same 
topological downstream connectivity found in the AHGFNetworkConnectivityDown 
table. This alternate way of serving up the connectivity information is designed to allow 
the Geofabric to be compatible with tooling included within ESRI’s ArcHydro for Surface 
Water Toolset. The NextDownID attribute, present on each AHGFNetworkStream 
feature, stores the HydroID of the next downstream feature. For cases where an 
AHGFNetworkStream feature has multiple downstream features (e.g. at a bifurcation), 
the HydroID of the first feature gets stored as the stream’s NextDownID and all 
subsequent downstream HydroIDs are stored as separate entries in the 
AHGFNetworkStream_FS table. 

Table 3 - Key attributes of the AHGFNetworkSegment_FS table for Surface Network 

(flow split table for use with ArcHydro tools) 

Key attribute Alias Description 
FeatureID FeatureID The HydroID for an AHGFNetworkStream segment 

NextDownID NextDownID The HydroID for the next downstream AHGFNetworkNode 
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2.5.1 Add subset feature classes and original tables 

1. In ArcMap, add the newly created subset feature classes to the MXD: 

 AHGFCatchment 

 AHGFNetworkNode 

 AHGFNetworkStream 

 AHGFWaterbody. 

2. Add the following SH_Network tables that were downloaded in step 2.1: 

 AHGFNetworkConnectivityDown 

 AHGFNetworkConnectivityUp 

 AHGFNetworkStream_FS. 
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2.5.2 Subset AHGFNetworkConnectivityDown 

1. In ArcMap, open the AHGFNetworkConnectivityDown table and choose Table 
Options > Joins and Relates > Join and join it to AHGFNetworkNode. 
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 Select From_ID for Choose the field this layer that the join will be based 
on:  

 Select AHGFNetworkNode for Choose the table to join to this layer, or load 
the table from disk:  

 Select HydroID for Choose the field in the table to base the join on: 

 Select Join Option Keep only matching records: 

 Choose [OK]. 
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2. Only the attributes for the AHGFNetworkConnectivityDown table are required in 
the SH-Network_MurrayDarling.gdb AHGFNetworkConnectivityDown table. This 
step will select all the joined, matching records and export only the 
AHGFNetworkConnectivityDown fields to the new AHGFNetworkConnectivityDown 
table. In the joined table,  

 Go to Table Options and click on Select All. The number of matching 
records will display at the bottom of the table. 

 Choose [Yes] to This table (potentially) contains a large number of records 
and the Select All operation could take a long period of time. Do you want 
to continue? 

 

 
 

 Go to Options > Joins and Relates > Remove Join(s) > AHGFNetworkNode 
to remove the AHGFNetworkNode table. 
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3. In the AHGFNetworkConnectivityDown table, click on the Show selected records 
button 

 

 
 

4. Export the selected records for the AHGFNetworkConnectivityDown table to its 
own new AHGFNetworkConnectivityDown table in the 
SH_Network_MurrayDarling.gdb.  

 In the AHGFConnectivityDown table go to Table Options and select Export 

 Ensure Export: Selected records is selected 

 Navigate to SH_Network_MurrayDarling.gdb 

 Save as type: File and Personal Geodatabase tables 

 Name: AHGFNetworkConnectivityDown 

 Click Save 

 Click OK 

 Click Yes to Do you want to add the new table to the current map? 
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2.5.3 Subset AHGFNetworkConnectivityUp 

1. Follow the same steps as outlined for Subset AHGFNetworkConnectivityDown. 

2. Export the selected records for the AHGFNetworkConnectivityUp table to its own 
new AHGFNetworkConnectivityUp table in the SH_Network_MurrayDarling.gdb.  

 In the AHGFNetworkConnectivityUp table go to Table Options and select 
Export 

 Ensure Export: Selected records is selected 

 Navigate to SH_Network_MurrayDarling.gdb 

 Save as type: File and Personal Geodatabase tables 

 Name: AHGFNetworkConnectivityUp 

 Click Save 

 Click OK 

 Click Yes to Do you want to add the new table to the current map? 
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2.5.4 Subset AHGFNetworkStream_FS 

1. In ArcMap, open the AHGFNetworkStream_FS table and choose Table Options > 
Joins and Relates > Join and join it to AHGFNetworkStream. 

 Select Feature_ID for Choose the field this layer that the join will be based 
on:  

 Select AHGFNetworkStream for Choose the table to join to this layer, or 
load the table from disk:  

 Select HydroID for Choose the field in the table to base the join on: 

 Select Join Option Keep only matching records: 

 Click OK. 
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2. Only the attributes for the AHGFNetworkStream_FS table are required in the SH-
Network_MurrayDarling.gdb AHGFNetworkStream_FS table. This step will select 
all the joined, matching records and export only the AHGFNetworkStream_FS 
fields to the new AHGFNetworkStream_FS table. In the joined, 

 Go to Table Options and click on Select All  

 Choose [Yes] to This table (potentially) contains a large number of records 
and the Select All operation could take a long period of time. Do you want 
to continue? 

 

 
 

 Go to Options > Joins and Relates > Remove Join(s) > 
AHGFNetworkStream to remove the AHGFNetworkStream table. 
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3. In the AHGFNetworkStream_FS table, go to Table Options and click on the Show 
selected records button. 

 

 

 

4. Export the selected records for the AHGFNetworkStream_FS table to its own new 
AHGFNetworkStream_FS table in the SH_Network_MurrayDarling.gdb.  

 In the AHGFNetworkStream_FS table go to Table Options and select Export 

 Ensure Export: Selected records is selected 

 Navigate to SH_Network_MurrayDarling.gdb 

 Save as type: File and Personal Geodatabase tables 

 Name: AHGFNetworkStream_FS 

 Click Save 

 Click OK 

 Click Yes to Do you want to add the new table to the current map? 

 

 
 

5. Close ArcMap to release any potential table locks when working in ArcCatalog. 
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2.6 Build a Geometric Network  

A geometric network is built to enable stream flow tracing. 

1. In ArcCatalog navigate to the File Geodatabase SH_Network_MurrayDarling 
created in step 2.2. 

2. Open the file geodatabase, right-click on the SH_Network feature dataset and 
choose New>Geometric Network…. 
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2.6.1 ArcGIS 10 (SP 3) 

In the Geometric Network Wizard: 

1. Choose [Next>]. 

2. Leave the geometric network name as the default (e.g. SH_Network_Net) and 
choose No to Snap features within specified tolerance. Click [Next>]. 

 

 

3. Click on Select All or add a check-mark to the AHGFNetworkNode and 
AHGFNetworkStream feature classes. Click [Next]: 
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4. Choose Yes for the question Do you want to preserve existing enabled attribute 
values?; Click [Next>]. 

5. Select the Role of Complex Edge for AHGFNetworkStream. Click [Next>]. 

 

 

6. No weights are added to the network. Click [Next>]. 
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7. Click [Finish] and when the network has finished being built there will be a 
geometric network object (e.g. SH_Network_Net) and a Junctions feature class 
(e.g. SH_Network_Net_Junctions) added to the SH_Network feature dataset. The 
Junctions feature class is automatically generated when a geometric network is 
created, but in this case it will be empty and can be ignored. 

2.6.2 ArcGIS 9.3 

In the Build Geometric Network Wizard: 

1. Choose [Next>]. 

2. Choose Build a geometric network from existing features for the question How do 
you want to build your geometric network?; Click [Next>]. 

3. Click to add a check-mark to the AHGFNetworkNode and AHGFNetworkStream 
feature classes and leave the network name as the default (e.g. 
SH_Network_Net); Click [Next>]. 

 

 

4. Choose Yes for the question Do you want to preserve existing enabled attribute 
values?; Click [Next>]. 

5. Choose Yes as the response for Do you want complex edges in your network? 
and ensure that AHGFNetworkStream has a check-mark next to it. Click [Next>]. 

6. Choose No for Do your features need to be snapped?; Click [Next>]. 

7. Choose No for Does your network have sources and sinks?; Click [Next>]. 

8. Choose No for Do you want to assign weights to your network?; Click [Next>]. 
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9. Click [Finish] and when the network has finished being built there will be a 
geometric network object (e.g. SH_Network_Net) and a Junctions feature class 
(e.g. SH_Network_Net_Junctions) added to the SH_Network feature dataset. The 
Junctions feature class is automatically generated when a geometric network is 
created, but in this case it will be empty and can be ignored. 

However, if there are nodes in the SH_Network_Net_Junctions feature class, 
please refer to the section 2.7 Geometric Network Errors. 
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2.7 Geometric network errors 

Surface Network is supplied with a geometric network which has connectivity. Every 
AHGFNetworkNode feature is connected to a AHGFNetworkStream feature. 

However, when creating a subset of Surface Network GDB, it is possible that ArcGIS 
will not select all the relevant AHGFNetworkNode features. This issue will be evident 
when a geometric network is built and there are features in the 
SH_Network_Net_Junctions feature class. 

The SH_Network_Net_Junctions features indicate where a network segment, in this 
instance AHGFNetworkStream, is interpreted by ArcGIS as missing a node at one or 
more of its ends. In order to create a geometric network, a network segment must 
have both a To and From node. 

2.7.1 Analyse SH_Network_Net_Junctions 

To analyse the SH_Network_Net_Junctions features: 

1. Open the ArcMap MXD which was used earlier in this tutorial. 

2. Add the SH_Network_Net_Junctions feature class to ArcMap. 

3. Zoom in to the individual features to confirm that nodes exist in the 
AHGFNetworkNode feature class at the end of the AHGFNetworkStream 
segments. 

2.7.2 ArcGIS 9.3  

The Geometric Network was created with no snapping. A new Geometric Network will 
need to be created with snapping. 

1. Delete the Geometric Network as described in step 2.2.1 

2. Create a Geometric Network. In the Build Geometric Network Wizard: 

 Choose [Next>]. 

 Choose Build a geometric network from existing features for the question 
How do you want to build your geometric network?; Click [Next>]. 

 Click to add a check-mark to the AHGFNetworkNode and 
AHGFNetworkStream feature classes and leave the network name as the 
default (e.g. SH_Network_Net); Click [Next>]. 

 Choose Yes for the question Do you want to preserve existing enabled 
attribute values?; Click [Next>]. 

 Choose Yes as the response for Do you want complex edges in your 
network? and ensure that AHGFNetworkStream has a check-mark next to 
it. Click [Next>]. 
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 Choose Yes for Do your features need to be snapped? and select 
AHGFNetworkNode feature class to be the data which is snapped ; Click 
[Next>]. 

 Choose No for Does your network have sources and sinks?; Click [Next>]. 

 Choose No for Do you want to assign weights to your network?; Click 
[Next>]. 

 Click [Finish] 

When the geometric network has been created, check that the 
SH_Network_Net_Junctions feature class is empty. 
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2.8 Set the flow direction of the network 

1. Download the Set Flow by Digitized Direction Command from the ESRI Developer 
Network ArcObjects Online website. 

2. Unzip the contents of the downloaded zip file (SetFlowByDigitizedDirection.zip) to 
an appropriate directory. 

3. Start ArcMap and add in the geometric network created above 
(SH_Network_Net). 

4. Add the Utility Network Analyst toolbar  

 In ArcGIS 10 go to Customize>Toolbars>Utility Network Analyst 

 In ArcGIS 9.3 go to View>Toolbars>Utility Network Analyst 

 

 
 

http://edndoc.esri.com/arcobjects/8.3/default.asp?URL=/arcobjects/8.3/samples/network/utility%20network%20analysis/flow%20by%20digitized%20direction/setflowbydigitizeddirection.htm
http://edndoc.esri.com/arcobjects/8.3/default.asp?URL=/arcobjects/8.3/samples/network/utility%20network%20analysis/flow%20by%20digitized%20direction/setflowbydigitizeddirection.htm
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5. In ArcGIS 10, click on Customize > Customize Mode…, in ArcGIS 9.3, click on 
Tools > Customize, 

Navigate to the MyFlowDirectionSolver.dll using the [Add From File] button on the 
Customize dialogue (the following message should be displayed). Click [OK]. 

 

 
 

6. Click on the Commands tab of the Customize dialogue, choose the Developer 
Samples commands category and add (drag-and-drop) the Set Flow by Digitized 
Direction command to the Utility Network Analyst toolbar. 

 

 
 

7. Choose Toolbars from the View menu and add in the Editor toolbar (if necessary) 
and start editing (Editor>Start Editing), select Network: SH_Network_Net from 
the drop down list. 

8. Click on the newly added tool ( ) to set the flow direction according to the 
digitized direction of the features.  
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9. Save your edits and finish the edit session (Editor>Save Edits; Editor>Stop 
Editing). 

10. Zoom to an area of interest. 

11. From the Utility Network Analyst toolbar, choose Flow>Display Arrows ( ) to 
turn on flow direction arrows. An arrow should display to indicate that the flow 
direction has been correctly set. 
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2.9 Trace upstream from a node in the network 

1. In ArcMap, Zoom to an area of interest. 

2. From the Utility Network Analyst toolbar, choose the Add Junction Flag Tool 
( ) and click on a feature from the AHGFNetworkNode feature class to add a 
flag for network tracing (green box in figure below). 
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3. Choose Trace Upstream from the Trace Task: menu on the Utility Network 
Analyst toolbar. 

4. Click on the Solve button ( ) on the Utility Network Analyst toolbar in order to 
perform the network trace.  

By default, the results of the trace operation will be displayed as red coloured 
drawing objects (this can be changed in Analysis > Options… on the Utility 
Network Analyst toolbar).  

Similarly, to select features instead of displaying as a different colour, this can be 
changed in Analysis > Options 
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5. Similarly, to select features instead of displaying as a different colour, this can be 
changed in Analysis > Options 

 

 
 

 In Results format, Return results as: Selection 

 Click [OK] 
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 Choose Trace Upstream from the Trace Task: menu on the Utility Network 
Analyst toolbar. 

 Click on the Solve button ( ) on the Utility Network Analyst toolbar in 
order to perform the network trace.  

The results of the trace operation will be displayed as selected features. 

 



 

 

 

 

Through the Water Act 2007, the Australian Government has given the Bureau of 
Meteorology responsibility for compiling and delivering comprehensive water 
information across Australia. 

For more information 
Visit our website at www.bom.gov.au/water 
Send an email request to waterinfo@bom.gov.au 
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