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1 Introduction 

This tutorial shows how to generate aquifer thickness from Geofabric Groundwater 

Cartography’s AHGFAquiferContour feature class. 

Three aquifers in South Australia will be used: 

 Murray Limestone Group (Tml); 

 Lower Renmark Group Aquifer, Tertiary Eocene Renmark (Ter1); and 

 Basement, Pre-Cainozoic (pcz). 

 

1.1 Aquifer thickness 

In this tutorial, the thickness of two aquifers will be calculated, using the top surfaces of 

the Murray Limestone Group (MLG), Lower Renmark Group (LRG) and Basement 

aquifers. 

 Thickness of MLG = Top of MLG surface – Top of LRG surface. 

 Thickness of LRG = Top of LRG surface – Top of Basement surface. 

1.2 AHGFAquiferContour 

This tutorial uses two fields in this feature class: 

 NameSynonm; and 

 IAF_ID. 

1.2.1 NameSynonm 

This field stores the names used for the aquifer unit.  
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1.2.2 IAF_ID 

This field is the Interim Aquifer ID field. It is the aquifer classification based on the 

Interim Aquifer Framework. 

More information is available in the Geofabric Product Guide: 

http://www.bom.gov.au/water/geofabric/documentation.shtml 

The three classifications, in order of depth sequence, used in this tutorial are: 

IAF_ID value IAF_ID description 

6 Upper Mid-Tertiary Aquifer (porous media - unconsolidated) 

10 Lower Tertiary Aquifer (porous media - unconsolidated) 

19 Palaeozoic and Pre-Cambrian Fractured Rock Aquifers (low permeability) 

1.3 Aquifer contour values 

The contour values for the aquifers used in this tutorial are: 

NameSynonm (Aquifer) Contour Value: 
From 

Contour value: 
To 

Murray Limestone Group (Tml) 100 -75 

Lower Renmark Group Aquifer, Tertiary Eocene 
Renmark (Ter1) 

75 -200 

Basement, Pre-Cainozoic (pcz) 100 -500 

Note contour values of 9999 indicate either fault lines or the formation is absent. 

1.4 Aquifer boundaries 

Geofabric Groundwater Cartography's AHGFAquiferBoundary feature class will be 

used in this tutorial to clip the aquifer output to the AHGFAquiferBoundary data. 

1.5 Contextual information 

Australia’s outline, the sea and State and Territory boundaries have been added to the 

following screen grabs to aid the interpretation of the aquifer contour data. 

1.6 ArcGIS 

1.6.1 Version 

The steps outlined in this tutorial use ArcGIS 10.1 (SP 1). 

1.6.2 Spatial Analyst extension 

The Spatial Analyst extension is required for this tutorial. 

1.7 Symbology 

The symbology used in this tutorial is based on the Geofabric Groundwater 

Cartography LYR file. 

http://www.bom.gov.au/water/geofabric/documentation.shtml
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1.8 Disclaimer 

This document is a guide only and is not to be used as a substitute for expert 

knowledge. 
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2 Tutorial 

2.1 Summary of steps 

These are the steps involved in calculating aquifer thickness. 

 Download Geofabric Groundwater Cartography. 1.

 Define the area of interest. 2.

 Clip AHGFAquiferContour data to the area of interest. 3.

 Convert AHGFAquiferContour to aquifer surfaces. 4.

 Calculate the thickness of the aquifer surfaces. 5.

2.2 Download Geofabric Groundwater Cartography  

 From the Bureau of Meteorology website (www.bom.gov.au) navigate to the 1.
Australian Hydrological Geospatial Fabric (Geofabric) page. Select the Geofabric 
FTP site link.  

 Select the GW_Cartography_GDB zip file and save this to disk. 2.

 

 

 Unzip the downloaded file. 3.

 In ArcCatalog, open the GW_Cartography_GDB folder. 4.

2.3 Add Groundwater Cartography data to ArcMap 

In this section, Groundwater Cartography feature classes will be added to ArcMap. 

http://www.bom.gov.au/
http://www.bom.gov.au/water/geofabric/index.shtml
ftp://ftp.bom.gov.au/anon/home/geofabric/
ftp://ftp.bom.gov.au/anon/home/geofabric/
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Geofabric Groundwater Cartography data can be added to ArcMap using two different 

methods. 

 Add the LYR file from the downloaded file. This will load the symbology for the 1.
whole Groundwater Cartography product.  

 Add the Geofabric Groundwater Cartography’s feature classes individually from 2.
the downloaded file. 

This tutorial will add two feature classes: 

 AHGFAquiferContour; and 

 AHGFAquiferBoundary (added later in the tutorial). 

2.3.1 AHGFAquiferContour 

 Open a new ArcMAP document. 1.

 In ArcCatalog,go to the unzipped GW_Cartography_GDB folder which was 2.
downloaded in step 2.2.  

 Expand the GW_Cartography_GDB folder.  3.

 Expand GW_Cartography.gdb 4.

 Expand the GW_Cartography feature dataset. 5.

 Select the AHGFAquiferContour featureclass. 6.
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 Drag it in to the new, empty ArcMap document’s Table of Contents window. The 7.
feature class default symbology category is AHGFFType (AHGF Feature Type).  

  

2.4 Symbolise IAF_ID 

The GW_Cartography_GDB folder contains a LYR file which symbolises all the feature 

classes in Groundwater Cartography based on national and international standards. 

In the LYR file, AHGFAquiferContour is symbolised according to depth sequence. This 

symbology will be used in the remainder of the tutorial. 

Follow the steps below to create your own AHGFAquiferContour LYR file, which will 

assist you in interpreting the position in geological time scale and relevant stratigraphy 

of the aquifers. 

2.4.1 Create AHGFAquiferContour LYR file 

 In ArcCatalog, go to the unzipped GW_Cartography folder which was 1.
downloaded in step 2.2.  

 Select the Geofabric Groundwater Cartography LYR – V2.1 LYR file and drag it 2.
in to the new, empty ArcMap document’s Table of Contents window. 

 Turn on the Geofabric Groundwater Cartography – V2.1 LYR file and expand the 3.
group layer. 

 Expand the Aquifer group layer.  4.

 Expand the Aquifer Contour group layer. 5.
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 Expand the AHGFAquiferContour Top layer. The symbology uses the IAF_ID 6.
field to reflect the depth sequence. All AHGFAquiferContour layers use IAF_ID 
and the same symbology. 
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 Save the symbology as a LYR file.  7.

 Right-click on AHGFAquiferContour Top and select Save as Layer File. 

 

 Navigate to the relevant directory and: 

 name the LYR file; 

 accept the default Save as type: Layer files (*.lyr); and  

 select Save. 

 

 Remove the Geofabric Groundwater Cartography – V2.1 LYR file from the 8.
ArcMAP’s Table of Contents. 
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2.4.2 Symbolise AHGFAquiferContour 

This section will symbolise the AHGFAquiferContour using the newly created LYR file. 

 In ArcMAP’s Table of Contents, right-click on the AHGFAquiferContour layer and 1.
select Properties. 

 In the Layer Properties window :Select the Symbology tab. The symbology will 2.
default to Categories > Unique values and display AHGFFeatureType as the 
Value Field. 

 For Value Field select IAF_ID. 

 Select Add All Values. All the IAF_ID values will be added with default 

symbology. 
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 Select Import. 3.

 Choose Import symbology definition from another layer in the map or from 

a layer file. 

 Choose Complete Symbology Definition in What do you want to import? 

 Navigate to the newly created AHGFAquiferContour LYR file. Select the 

LYR file and select Add. 

 

 Select OK to close the Import Symbology window. 

 In the Import Symbology Matching Dialog window, change the Value Field to 4.
IAF_ID so that the AHGFAquiferContour feature class data uses the same field 
that has been defined in the LYR file. 

 

 The Layer Properties’ Symbology tab will update with the IAF_ID symbology. 5.
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 Select OK to close the Layer Properties window.  6.

 AHGFAquiferContour will display with the IAF_ID symbology. ArcMAP does not 7.
display the IAF_ID symbology in the correct depth sequence by default. For 
example, the Mesozoic data displays on top of the Jurassic data. This will be 
corrected in the next step. 

 

  



Australian Hydrological Geospatial Fabric (Geofabric) Tutorial 
Calculate aquifer thickness 

July 2014 | Geofabric Version 2.1 12 
 

 

 To display the correct depth sequence, follow these steps. 8.

 Right-click on AHGFAquiferContour and select Properties. 

 Select the Symbology tab and select Advanced > Symbol Levels. 

 

 Check the box for Draw this layer using the symbol levels specified below. 

 Select OK to close the Symbol Levels window. 

 Select OK to close the Layer Properties window. 
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 The depth sequence now displays correctly; for example the Jurassic data is 9.
drawn on top of Mesozoic data. 

 

 Alternatively, Symbol Levels can also be turned on by right-clicking 10.
AHGFAquiferContour and selecting Symbol Levels. 
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2.5 Extract aquifers in South Australia 

The aquifer area of interest in this tutorial is in South Australia, but the chosen aquifiers 

also extend into Victoria and New South Wales.  

 

For the purposes of this tutorial, Definition queries will be created to clip the aquifers to 

the South Australia boundary and export them from the aquifer contour feature class to 

shapefiles. The following three aquifers will be used: 

 Murray Limestone Group (Tml); 

 Lower Renmark Group Aquifer, Tertiary Eocene Renmark (Ter1); and 

 Basement, Pre-Cainozoic (pcz). 
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2.5.1 Murray Limestone Group (Tml) 

2.5.1.1 Create a Definition query 

 Right-click on AHGFAquiferContour and select Properties. 1.

 In the Layer Properties window: 2.

 select the Definition Query tab; and 

 select Query Builder. 

 

 In the Query Builder window carry out these steps. 3.

 Double-click "NameSynonm". 

 Select Get Unique Values. 

 For Go To, type Murray. 

 For SELECT * FROM AHGFAquiferContour WHERE enter the query, 

“NameSynonm” = ‘Murray Limestone Group (Tml)’. 

 

 Select OK to close the Query Builder window. 4.
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 Select OK to close the Layer Properties window. 5.
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2.5.1.2 Export to shapefile 

 Right-click on AGHFAquiferContour and select Data > Export Data. 1.

The Export Data window requires these selections. 

 For Export, select All features. 

 For Use the same coordinate system as, select this layer’s source data. 

 For Output feature class, navigate to the relevant folder. 

 In the Saving Data window carry out these steps. 2.

 Enter a name for the Murray Limestone Group aquifer output. 

 Select the file type in Save as type. 

 Select Save to return to the Export Data window. 

 

 Select OK to export the data. 

 When asked Do you want to add the exported data to the map as a layer?, 

select Yes. 
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2.5.2 Lower Renmark Group Aquifer, Tertiary Eocene Renmark (Ter1) 

2.5.2.1 Create a Definition Query 

Follow the steps for Murray Limestone Group. 

 In the Layer Properties window’s Definition Query tab carry out these steps. 1.

 Delete the query for 'Murray Limestone Group (Tml)'. 

 Select Apply to delete the query. 

 Select Query Builder. 

 In the Query Builder window enter the Definition Query as "NameSynonm" = 2.
'Lower Renmark Group Aquifer, Tertiary Eocene Renmark (Ter1)'. 

 

2.5.2.2 Export to shapefile 

Follow the steps for Murray Limestone Group. 
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2.5.3 Basement, Pre-Cainozoic (pcz) 

2.5.3.1 Create a Definition Query 

Follow the steps for Murray Limestone Group. 

 In the Layer Properties window’s Definition Query tab follow these steps. 1.

 Delete the existing query. 

 Select Apply to delete the query. 

 Select Query Builder. 

 In the Query Builder window, enter the Definition Query as: "NameSynonm" = 2.
'Basement, Pre-Cainozoic (pcz)'. 

 

2.5.3.2 Export to shapefile 

Follow the steps for Murray Limestone Group. 
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2.6 Clip aquifer contours to area of interest 

Only the aquifer contours in South Australia will be used in this tutorial, as defined by 

the red rectangle in the screen grab below,. These will be clipped and exported to new 

shapefiles. 
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2.6.1 Create clip mask 

Use the Draw toolbar to create a rectangular clipping mask to clip all three aquifers. 

The rectangle graphic will be converted to a shapefile for clipping the aquifer contours. 

 Go to Customize > Toolbars to turn the Draw toolbar on. 1.

 From the Draw toolbar, select the Rectangle shape. 2.

 

 Draw the clipping mask so that it covers the aquifer contours in South Australia. 3.

 Change the properties of the rectangle by right-clicking on the rectangle and 4.
selecting Properties. 

 In the Properties window, change the Fill Color, Outline Color and Outline Width 5.
to make the graphic visible against the aquifer contours. 

 Select OK to close the Properties window. 6.

 If necessary, edit the graphic so that its extent is correct. 7.

 From the Draw toolbar, go to Drawing and select Convert Graphics to Features. 8.
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 In the Convert Graphics to Features window follow these steps. 9.

 For Convert choose Polygon graphics. 

 Tick the box Selected graphics only. 

 For Use the same coordinate system as, choose the data frame. 

 Navigate to a directory to save the Output shapefile or feature class. 

 Select the file type in Save as type. 

 Select Save to close the Saving Data window. 

 Tick the box Automatically delete graphics after conversion. 

 

 Select OK to close the Convert Graphics to Features window. 

 Select Yes when asked Do you want to add the exported data to the map as a 10.
layer? 
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2.6.2 Clip aquifer contours 

 In ArcMAP, open ArcToolbox from the Standard toolbar. 1.

 

 Go to Analysis Tools > Extract > Clip tool. 2.

 

 Double-click on the Clip tool and populate the parameters as follows. 3.

 For Input Features select 

(AHGFAquifierContour_MurrayLimestoneGroup_SA) from the drop-down 

box. 

 For Clip Features select Clip_mask. 

 Navigate to a folder to save the Output Feature Class. 

 Leave the XY Tolerance blank. 

 

 Select OK to run the tool. 

 The clipped feature class is automatically added to ArcMAP.  4.

 Repeat the above process for the other two aquifer contour shapefiles. 5.
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 The clipped aquifer contours will be confined to the South Australian border, as 6.
shown (symbolised using the AHGFAquiferContour LYR file). 
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2.7 Convert aquifer contours to aquifer surfaces 

ArcToolbox’s Spatial Analyst Tools is used to convert the clipped, aquifer contour 

shapefiles to aquifer surfaces. 

The top surfaces of the aquifers will be used to calculate the thickness of the aquifers. 

For the calcuations to be accurate it is important that all the input features classes use 

the same projection and the same cell size. 

2.7.1 Spatial Analyst extension 

In ArcMAP, turn on the Spatial Analyst extension, then: 

 go to the Customize menu; 

 select Extensions; 

 select Spatial Analyst; and 

 select Close. 

2.7.2 ArcToolbox - Topo to Raster tool 

This tool converts the AHGFAquiferContour data to an aquifer surface. 

 In ArcToolbox, go to Spatial Analyst Tools > Interpolation > Topo to Raster tool. 1.

 Double-click on the tool to open it. 2.

 Populate for the three aquifers according to the instructions below. 3.

2.7.3 Murray Limestone Group 

2.7.3.1 Topo to Raster tool 

 For Input feature data select the Murray Limestone Group data for South 1.
Australia. The data will be automatically added to Feature layer list.  

 In the Feature layer list, select the Field drop-down list to change the default field 2.
OBJECTID to ContValue. Check that Type is Contour. 

 Navigate to your directory to save the Output surface raster as a GRID file (note 3.
this is restricted to a thirteen-character filename). 

 For Output cell size enter 0.0045 decimal degrees, which is approximately 500 4.
metres. 

 Select Drainage enforcement from the drop-down list to be NO_ENFORCE (as 5.
sinks are not related to hydrogreology). 

 Accept the Primary type of input data as CONTOUR. 6.

 Accept all other parameters’ default values. 7.
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 Select OK to create the raster surface. 8.
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2.7.3.2 Default output raster surface 

The raster surface will be automatically added to ArcMap with the default symbology 

shown in the screen grab below. 

AHGFAquiferContours for the Murray Limestone group have been added and labelled. 

 

The raster surface’s default symbology has nine classes of values. 
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2.7.3.3 Edit classes and classification values 

Change the classes and their values to reflect the contour values. 

 Right-click on the murraylimestn layer and select Properties. 1.

 Change the Classes from nine to eight. 2.

 Select Classify to reclassify the data. 3.
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 In the Classification window edit the Break values to the contour values. 4.

 

 The contour values for this aquifer are shown in the edited Break Values in 

the screen grab below. 

 

 Select OK to close the Classification window. 
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 In the Layer Properties window: 5.

 change the Color Ramp to display the colours more clearly; 

 format the labels to show no decimal places; 

 edit the labels to show the ranges clearly by substituting "-" with "to"; and 

 select OK to close the Layer Properties window. 

 The edited classes will be updated in the Table of Contents. 6.

 Edit <VALUE> to " Top of Aquifer Elevation (mAHD)". 7.
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 Examine the raster surface classes against the AHGFAquifercontour data. 8.
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2.7.4 Lower Renmark Group 

2.7.4.1 Topo to Raster tool 

Follow the same steps as Murray Limestone Group, substituting Lower Renmark Group 

where applicable. 

2.7.4.2 Default output raster surface 

The default raster surface output will display as per the screen grab below.  

 

The default classes will display in the Table of Contents as per the screen grab below. 
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2.7.4.3 Edit classes and classification values 

 Edit the number of classes from nine to 12 and edit the Break values to reflect 1.
the contour values. 

 

 The raster surface will display as per the screen grab below. 2.
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2.7.5 Basement Pre–Cainozoic 

Creating this aquifer surface requires a preliminary step.The AHGFAquiferContour data 

contains contour values of 9999. These indicate either fault lines or the formation is 

absent. They will skew the output raster surface, so need to be removed before 

conversion. 

The screen grab below shows the 9999 contour values. 
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2.7.5.1 Remove contour values 9999 

 Right-click on the AHGFAquiferContour layer in the Table of Contents and select 1.
Properties. 

 In the Layer Properties window select the Definition Query tab and select Query 2.
Builder. 

 In the Query Builder window: 3.

 scroll down to “ContValue” and double-click on it so that it appears in the 

bottom window; 

 select <>; 

 select Get Unique Values; 

 scroll to the bottom and double-click on 9999; and 

 

 select OK to close the Query Builder. 

 Select OK to close the Layer Properties window. 4.
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2.7.5.2 Export to a new shapefile 

Export the data (now without 9999 values) to a new shapefile. 

 Right-click on the AHGFAquiferContour layer and select Data > Export Data. 1.

 In the Export Data window select the following options. 2.

 For Export choose All features. 

 For Use the same coordinate system as, choose this layer’s source data. 

 For Output feature class, select the output directory and name the output 

file. 

- Navigate to a directory. 

- For Name choose a name for the output file. 

- For Save as type, choose Shapefile. 

- Select Save to close the Saving Data window. 

 

 Select OK to close the Export Data window. 3.

 Select [Yes] to Do you want to add the exported data to the map as a layer? 4.

 This layer will be used to create a raster surface. 5.
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2.7.5.3 Topo to Raster tool 

Follow the same steps as Murray Limestone Group, substituting Basement Pre–

Cainozoic where applicable. 

2.7.5.4 Default output raster surface 

The default raster surface output will display as per the screen grab below. 

 

 

The default classes will display in the Table of Contents as per the screen grab below. 
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2.7.5.5 Edit classes and classification values 

 Edit the number of classes from nine to 18 and edit the Break values to reflect 1.
the contour values. Note that the contour interval varies between 25 metres and 
50 metres. 
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 The raster surface will display as per the screen grab below. 
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2.8 Clip Raster Surfaces to Aquifer Boundary extents 

The raster surfaces for Murray Limestone and Lower Renmark extend beyond their 

aquifer extents and need to be clipped to their respective aquifer boundaries.  

Geofabric Groundwater Cartography includes Aquifer Boundary data which will be 

used in the following steps to clip these raster surfaces. 

2.8.1 AHGFAquiferBoundary 

 In ArcCatalog, navigate to the unzipped GW_Cartography folder which was 1.
downloaded in step 2.1.  

 Select the AHGFAquiferBoundary featureclass. 2.

 Drag it in to the ArcMap document’s Table of Contents window. 3.
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The boundaries for Murray Limestone and Lower Renmark are stored in the Name 

Synonms field and will be extracted individually from the AHGFAquiferBoundary data in 

the following steps. 

 Right-click on AHGFAquiferBoundary and select Open Attribute Table. 1.

 In Table Options, go to Select by Attributes. 2.

 In the Select by Attributes window, compose the following SQL query to select 3.
the AHGFAquiferBoundary.  

 "NameSynonm" = 'Murray Limestone Group (Tml)'. 

 "NameSynonm" = 'Lower Renmark Group Aquifer, Tertiary Eocene 

Renmark (Ter1)'. 

 In the screen grab below, Murray Limestone has been selected. 4.

 

 Select Apply. 5.

 One record will be selected in the AHGFAquiferBoundary table. 6.

 In ArcMap Table Of Contents, right-click on the AHGFAquiferBoundary layer and 7.
select Data > Export Data. 

  



Australian Hydrological Geospatial Fabric (Geofabric) Tutorial 
Calculate aquifer thickness 

July 2014 | Geofabric Version 2.1 42 
 

 In the Export Data window, choose the following parameters. 8.

 For Export choose Selected features. 

 For Use the same coordinate system as, choose this layer’s source data. 

 For Output feature class, navigate to a directory, save the output and select 

Save. 

 Select OK. 

 

 When asked Do you want to add the exported data to the map as a layer, select 9.
Yes. 

 In the Table of Contents, right-click and select Zoom to Layer to see the extent of 10.
the aquifer boundary in relation to the AHGFAquiferContour data and the newly 
generated raster surface. Note how the AHGFAquiferContour data and 
AHGFAquiferBoundary data have similar extents. 

Murray Limestone 
 

Lower Renmark 
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2.8.2 Clip raster surface to aquifer boundary extent 

The raster surfaces will be clipped to the perimeter of the respective aquifer 

boundaries. 

 In ArcToolbox, go to Data Management > Raster > Raster Processing > Clip. 1.

 Right-click on Clip and select Open.  2.

 In the Clip window, populate the parameters as follows: 3.

 For Input Raster select Murray Limestone raster surface or Lower Renmark 

raster surface. 

 For Output Extent select AHGFAquiferBoundary_MurrayLimestone or 

AHGFAquiferBoundary_LowerRenmark. 

 For Use Input Features for Clipping Geometry, tick the box. This will clip the 

input raster to the perimeter of the output extent. 

 For Output raster dataset, select a location and filename, remembering that 

the GRID's file name is restricted to 13 characters. 

 For NoData value, accept the default. 

To check the NoData value in the Input Raster, right-click on the raster layer in the 

Table of Contents > Layer Properties and select the Source tab. Scroll down in the 

Raster Information and note the NoData Value. 

 

 Select OK to run the tool. 4.
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 The output is automatically added to ArcMAP. 5.

Murray Limestone Lower Renmark 
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 If required, symbolise the No Data values.  6.

 Right-click on the clipped raster surface and select Properties > 

Symbology. 

 In the Layer Properties window the Display NoData as will have no colour. 

Select a colour and select OK. 

 

 The data will display as per the screen shots below. 

Murray Limestone Lower Renmark 
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2.9 Visualise aquifer surfaces 

The aquifer surfaces that have been created using the Topo to Raster tool can be 

visualised using ArcScene.  

Please refer to the Geofabric tutorial Visualise Aquifer Surfaces, which is available from 

http://www.bom.gov.au/water/geofabric/documentation.shtml. 

This provides instructions on how to display the three surfaces in relation to each other, 

as shown in the screen grab below. 

 

 

  

http://www.bom.gov.au/water/geofabric/documentation.shtml
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2.10  Calculate aquifer thickness 

Two aquifer thicknesses will be calculated from the three aquifer surfaces by a process 

of subtraction, using the raster surfaces created in the previous steps: Murray 

Limestone Group and Lower Renmark Group. 

Note that this requires the Spatial Analyst extention, which was installed in step 2.7.1. 

2.10.1 ArcToolbox – Raster Calculator 

Open the Raster Calculator to calculate aquifer thicknesses. 

 In ArcToolbox, go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 1.

 Double-click on Raster Calculator to open the tool. 2.
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2.10.2 Murray Limestone Group 

In this step the thickness of the Murray Limestone Group aquifer is calculated using the 

Raster Calculator. The output is automatically added to ArcMap and is then classified 

in consistent depth intervals and symbolised accordingly. 

2.10.2.1  Raster Calculator 

 From the raster layers, subtract the Lower Renmark aquifer raster from the 1.
Murray Limestone raster. 

 Compose an expression which will look something like the following 

(“Murray Limestone” and “Lower Renmark” are the names of the Group 

Layers in the ArcMap Table of Contents.)  

 Select a location and name for the Output Raster. (Note the file name is limited to 2.
13 characters.)  

 Select OK to calculate the thickness. 3.
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2.10.2.2  Classify and symbolise aquifer thickness 

The output will be automatically added to ArcMap’s Table of Contents with the default 

symbology and values shown in this sreen grab: 
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Classify the output into 25 metre thickness intervals. 

 Right-click on the Murray Limestone thickness layer and select Properties. 1.

 In the Layer Properties window go to the Symbology tab. 2.

 For Show select Classified. In the next window when asked, The Classified 

renderer requires the data to have a histogram; Do you want to compute 

the histogram?, select Yes. The symbology will change to five classes. 

 In Classes change the number from five to eight. 

 

 Select Classify.  

 In the Classification window, edit the Break Values to increments of 25 

metres, starting at 0. 

 

 Select OK to close the Classification window. 
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 Select a Color Ramp, if the default colours are not suitable.

 Negative thickness values need to be changed to a colour to indicate

incorrect or missing data. In this example the colour is black.

 Labels can also be formatted to set the number of decimal places to 0 and

improve the legibility of the negative values by editing ‘-12 – 0’ to ‘-12 to 0’.

 Select OK to close the Layer Properties window.

 ArcMap will be updated to display the legend and data. 3.
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Edit <VALUE> to Isopachs (metres).4.
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2.10.3 Lower Renmark 

In this step, calculate the thickness of the Lower Renmark aquifer by subtracting the 

Basement raster from it. Repeat the steps as for Murray Limestone Group in step 

2.10.2, substituting the Lower Renmark and Basement rasters as applicable. The 

screen grabs illustrate the outputs. 
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Note you will use 16 classes to classify the thickness in increments of 25 metres. 
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